HTTP/2 wordpress cu iframe-uri

Eduard E

Active Member
Registered
Banned
Salut.
De curand incerc sa migrez catre http/2 ... din ce stiu este 100% necesar si activarea https ... acum de cand cu problema cu free https keys nu e asa simplu (alta poveste) ... problema intervine cand ai un site in care 99% din content contine iframe, lucru pe care il stiu ca intrerupe https-ul. In concluzie intrebarea mea este daca cineva de aici a incercat treaba asta sau daca are cunostinte despre migrare. Nu ma refer la partea de install efectiva, alea se gasesc pe google, ci doar daca si cum se aplica pe pagini in care ai incluse inframeuri si daca influenteaza cu ceva sau nu.
 

Naruto9

VIP Club
Registered
Full Member
Web Designer
VIP Club
Salut.
De curand incerc sa migrez catre http/2 ... din ce stiu este 100% necesar si activarea https ... acum de cand cu problema cu free https keys nu e asa simplu (alta poveste) ... problema intervine cand ai un site in care 99% din content contine iframe, lucru pe care il stiu ca intrerupe https-ul. In concluzie intrebarea mea este daca cineva de aici a incercat treaba asta sau daca are cunostinte despre migrare. Nu ma refer la partea de install efectiva, alea se gasesc pe google, ci doar daca si cum se aplica pe pagini in care ai incluse inframeuri si daca influenteaza cu ceva sau nu.
daca te referi la iframe de genul openload/netu atunci pentru a functiona url-ul trebuie sa trimita tot catre o adresa securizata(https) . Daca ai in site iframe-uri, imagini sau alte elemente cu http(css, js etc) acelea vor genera o eroare si nu vor fi redate de catre browser.
 

Eduard E

Active Member
Registered
Banned
daca te referi la iframe de genul openload/netu atunci pentru a functiona url-ul trebuie sa trimita tot catre o adresa securizata(https) . Daca ai in site iframe-uri, imagini sau alte elemente cu http(css, js etc) acelea vor genera o eroare si nu vor fi redate de catre browser.
Asta am spus si eu, dar reformulez: Pentru a rula http/2 e nevoie de https obligatoriu. Cu iframe se duce naibii https, deci e o problema si pentru http/2?
 

Naruto9

VIP Club
Registered
Full Member
Web Designer
VIP Club
Asta am spus si eu, dar reformulez: Pentru a rula http/2 e nevoie de https obligatoriu. Cu iframe se duce naibii https, deci e o problema si pentru http/2?
Nu contează ca ai http sau http/2 . Întrebarea ta ține de certificatul ssl . Openload oferă de exemplu https, netu la fel și mulți alții. Cele vechi trebuiesc modificate(manual sau automat cu ajutorul unui programator).
PS: Recomand http/2 dacă există posibilitatea. Recomand de asemenea și versiuni noi de php ( 7.1 de exemplu). S-a demonstrat că php 7.1 e de 2x mai rapid decât versiunea 5.6 și cu toate astea foarte multe site-uri wordpress nu au făcut upgrade.
PPS: Răspunsul strict la întrebarea ta este DA. Se duce ”naibii” și cu http/2 :)))
 

AlexH

Merg pe strada catre Mine...
Membru personal
Administrative
Freelancer
SEO Expert
1, Multe firme de hosting inca nu au implementat php 7 si chiar daca il au cand doresti sa schimbi este un avertisment care iti spune ca e posibil sa nu iti functioneze.
2. Se stie ca php7 a eliminat si adaugat module care face ca vechile scripturi sau theme/plugin sa nu functioneze
3. Http2 se poate instala din WHM la sectiunea EasyApache 4 https://documentation.cpanel.net/display/EA4/Apache+Module:+HTTP2 Nu functioneaza pe sisteme 32bit
4. Cunosc persoane care detin site-uri si nu le functioneaza pe 5.6, iar versiunea 7 nici nu intra in discutie.
Link care pot ajuta
http://httpwg.org/specs/rfc7540.html#FramingLayer
https://httpd.apache.org/docs/2.4/howto/http2.html

Cred ca ar trebui sa discutam mai mult pe acest subiect.
 

Naruto9

VIP Club
Registered
Full Member
Web Designer
VIP Club
1, Multe firme de hosting inca nu au implementat php 7 si chiar daca il au cand doresti sa schimbi este un avertisment care iti spune ca e posibil sa nu iti functioneze.
2. Se stie ca php7 a eliminat si adaugat module care face ca vechile scripturi sau theme/plugin sa nu functioneze
3. Http2 se poate instala din WHM la sectiunea EasyApache 4 https://documentation.cpanel.net/display/EA4/Apache+Module:+HTTP2 Nu functioneaza pe sisteme 32bit
4. Cunosc persoane care detin site-uri si nu le functioneaza pe 5.6, iar versiunea 7 nici nu intra in discutie.
Link care pot ajuta
http://httpwg.org/specs/rfc7540.html#FramingLayer
https://httpd.apache.org/docs/2.4/howto/http2.html

Cred ca ar trebui sa discutam mai mult pe acest subiect.
Folosesc php 7.1 pentru un site de-al meu(tu îl știi care e) și am http/2.0 activat. Vedeți totuși că cei de la cloudflare au o setare prin care poți activa. Dacă puneți certificat de la cloudflare (precum topicul făcut de AlexH - căutați la tutoriale) o să puteți să activați și http/2.0 foarte ușor și simplu :)
PS: Puteți testa dacă site-ul vostru are(sau odată pus dacă funcționează corect) http/2.0 cu extensia asta ==> https://chrome.google.com/webstore/...icator/mpbpobfflnpcgagjijhmgnchggcjblin?hl=en
 

Eduard E

Active Member
Registered
Banned
Pana la urma am rezolvat, merci pt ajutor, am trecut la http/2 cu nginx, php 7.1 il foloseam de ceva timp, implementat redis ca front-cache la database, memcache pt php, https peste tot, totul se misca super bine acum. In plus am renuntat la file cache (wp rocket) si nu folosesc decat cloudflare-ul pentru a micsora java, html si css. Putine optimizari la php-fpm sa se descurce cu numarul de cereri, vreau sa spun ca "zboara" ... partea buna e ca nu trebuie sa ma mai chinui acum cu "sters cache" cand e content nou, si alte balarii de genul asta. Nu i-am facut nici un test inainte si dupa pentru un gtmetrix dar am impresia ca se misca mai bine. Cireasa de pe tort e ca toti retardatii aia cu site-urile lor care imi tot copiau continutul au fost pe faza si s-au miscat repede in a schimba site-ul pe care-l cloneaza (in maxim 1-1h.30)... Care nu a apucat sa schimbe, primeste zero vizite pentru ca intra eroarea de la https :) si nici un content nu este afisat. RIP.
 

Naruto9

VIP Club
Registered
Full Member
Web Designer
VIP Club
Pana la urma am rezolvat, merci pt ajutor, am trecut la http/2 cu nginx, php 7.1 il foloseam de ceva timp, implementat redis ca front-cache la database, memcache pt php, https peste tot, totul se misca super bine acum. In plus am renuntat la file cache (wp rocket) si nu folosesc decat cloudflare-ul pentru a micsora java, html si css. Putine optimizari la php-fpm sa se descurce cu numarul de cereri, vreau sa spun ca "zboara" ... partea buna e ca nu trebuie sa ma mai chinui acum cu "sters cache" cand e content nou, si alte balarii de genul asta. Nu i-am facut nici un test inainte si dupa pentru un gtmetrix dar am impresia ca se misca mai bine. Cireasa de pe tort e ca toti retardatii aia cu site-urile lor care imi tot copiau continutul au fost pe faza si s-au miscat repede in a schimba site-ul pe care-l cloneaza (in maxim 1-1h.30)... Care nu a apucat sa schimbe, primeste zero vizite pentru ca intra eroarea de la https :) si nici un content nu este afisat. RIP.
he he..bagă și cache-ul(wp rocket) că e bun :) La trafic mic nu se simte, dar la trafic mare e recomandat să ai cache. În plus și cei de la cloudflare spun că e ok dar trebuie să îl setezi cum trebuie :)
Îți recomand tutorialul oficial de la cloudflare: https://support.cloudflare.com/hc/e...aching-Static-HTML-with-WordPress-WooCommerce
 

Eduard E

Active Member
Registered
Banned
he he..bagă și cache-ul(wp rocket) că e bun :) La trafic mic nu se simte, dar la trafic mare e recomandat să ai cache. În plus și cei de la cloudflare spun că e ok dar trebuie să îl setezi cum trebuie :)
Îți recomand tutorialul oficial de la cloudflare: https://support.cloudflare.com/hc/e...aching-Static-HTML-with-WordPress-WooCommerce
Aici gresesti, rau de tot :p Ce face rocketu ? Daca presupui ca trimite doar un fisier static, gresesti. E un proces in plus care nu intereseaza pe nimeni, el pastreaza in html deja ceea ce se proceseasa in baza de date, astfel incat sa nu mai fie nevoie de procesarea bazei de date din nou. CORECT pana aici, DAR daca pui content nou, si destul de mult, trebuie sa stergi pagini la fiecare update pentru a fi aratate public. Cu redis, totul se reduce la acelasi lucru, DOAR ca totul este automat, baza de date nu este atinsa decat daca este un update la articol , iar daca este asa ceva, se face si pentru celelalte "pagini" care contin acelasi continut, sa spunem o lista cu ultimele articole.
Chiar asa sa luam o lista cu "ultimele articole", daca schimbi titlul, in wp rocket o sa ramana la fel pagina care tine lista de articole daca nu ii dai remove cache. Prin redis se duc toate concomitent, in plus sunt facute "preload", adica nu e nevoie de o accesare propriuzisa pentru a incarca in cache datele noi. Daca nu stii despre ce este vorba cu redis, cauta pe google ca ai de unde. Pe scurt, punand si rocket ingreunez site-ul cu cateva requesturi in plus, degeaba.
 
Loading...
Sus