Tutorial Wordpress si SSL Flexible - Metoda care functioneaza

AlexH

Merg pe strada catre Mine...
Membru personal
Administrative
Freelancer
SEO Expert
#1
Daca ati incercat sa treceti site wordpress pe ssl oferit de cloudflare si va da eroare, mai jos gasiti solutia.
Erori intalnite dupa activare si schimbat in wp-admin > setari url din http in https
1. imaginile nu se afiseaza pentru ca raman cu http si nu se afiseaza sub ssl
2. cand va logati la wp-admin va da eroare ca sunt prea multe redirectari
3. uneori eroare de css

Setari care functioneaza:

1. dezactivati ssl in cloudflare
2. instalati pluginul cloudflare https://wordpress.org/plugins/cloudflare/
3. activati plugin si va logati cu adresa email si key
4. mergeti in cloudflare si activati SSL Flexible
5. in wp-admin > setari schimbati din http in https
6. daca aveti cache stergeti si acum totul ar trebui sa functioneze

O alta metoda care functioneaza in unele cazuri fara plugin:
1. login in wp-admin sau intrati pe baza de date si schimbati la siteurl din http://site.com in //site.com
 

AlexH

Merg pe strada catre Mine...
Membru personal
Administrative
Freelancer
SEO Expert
#3
In cazul in care nu vrea si chiar nu vrea sa mearga, iar site-ul arata fara css si imagini
Metoda recomandata de tine este cand folosesti resurse css, img,js externe si care nu ruleaza cu https.
Daca aceste resurse sunt interne atunci metoda din primul post rezolva totul.
 

WPMT

Active Member
Registered
Full Member
#4
Problema cu prea multe requesturi in wp-admin la trecerea pe ssl cloudflare am intalnit-o si noi.
Solutia aplicata de noi:
  1. Logare pe site-ul cloudflare
  2. Click pe butonul "Crypto"
  3. La SSL se alege FULL sau FULL (restricted)
  4. Se aceseaza site.ro/wp-admin
  5. Se instaleaza si se activeaza pluginul "CloudFlare Flexible SSL"
  6. Se modifica pe cloudflare inapoi la Flexible SSL
 

AlexH

Merg pe strada catre Mine...
Membru personal
Administrative
Freelancer
SEO Expert
#5
La SSL se alege FULL sau FULL (restricted)
Din motive care nu le inteleg inca, aceasta optiune nu functioneaza la wordpress pe unele site-uri, desi orice alt site pe acelasi host functioneaza fara probleme.
 

AlexH

Merg pe strada catre Mine...
Membru personal
Administrative
Freelancer
SEO Expert
#7
Din cate vad nu ai facut setarile in cloudflare bine la sectiunea ssl.
Cand iti accesez site apare cu rosu si avertizare.
Voi face un tutorial special pentru asta astazi.
 
Ultima editare:

adamas

Active Member
Registered
Full Member
#9
Update:
Este un tutorial aici http://www.roforum.net/threads/ssl-gratis-de-la-cloudflare.4325/
Daca vrei unul in imagini sa ma anunti.
eu am incercat zilele astea toate metodele pe care le-am gasit in topicurile de pe roforum, dar ceva fac gresit ca nu imi iese tot.
acuma mai incerc si varianta asta.
o chestie ciudata este ca in wp-admin si in dashboardul de la site imi arata ca are ssl, dar pe site nu imi apare. in dashboard imi apare ca am lacatul ala verde, dar pe site nu am lacatul verde.
 

WPMT

Active Member
Registered
Full Member
#11
eu am incercat zilele astea toate metodele pe care le-am gasit in topicurile de pe roforum, dar ceva fac gresit ca nu imi iese tot.
acuma mai incerc si varianta asta.
o chestie ciudata este ca in wp-admin si in dashboardul de la site imi arata ca are ssl, dar pe site nu imi apare. in dashboard imi apare ca am lacatul ala verde, dar pe site nu am lacatul verde.
Lacatul verde poate sa nu iti apara pe site si din cauza ca incarci elemente fara ssl (imgaini, scripturi js etc)
 
Sus