Free CDN pentru poze

crystygye

Well-Known Member
Registered
Full Member
#1
Ce alt free cdn pentru imagini, pentru wordpress stiti? jetpack nu il pot face sa se connecteze sub nici o forma de cand am tercut pe php7.
Mai este vreun cdn doar pentru poze precum photon?
 

crystygye

Well-Known Member
Registered
Full Member
#3
Doar am facut update de php de la 5 la 7. De atunci nu a mai mers deloc.
Am instalat xml si activat in consola. Cand intru pe link imi raspunde cum trebuie.
"XML-RPC server accepts POST requests only."
Dar jetpack nu se poate connecta. Dropletul a primit doar update de php, atata tot. Nimic altceva.

Imi da mesaj asta in consola jetpack:
[body] => {"error":"XML-RPC is not responding correctly ( 200 )","error_description":"It looks like XML-RPC is not responding correctly. Please make sure XML-RPC is turned on for your site and is set up to respond to all content types.
[response] => Array
(
Cod:
 => 400
            [message] => Bad Request[/quote]
 

AlexH

Merg pe strada catre Mine...
Membru personal
Administrative
Freelancer
SEO Expert
#4
Pai normal, este cum ti-am spus mai sus, ai XML-RPC blocat, restrctionat.
Testeaza asta:
In function.php inainte ?> adauga linia asta:
Cod:
add_filter(‘xmlrpc_enabled’, ‘__return_false’);
Alta optiune unde specfici ip la server/site.
Cod:
# Block WordPress xmlrpc.php requests
<Files xmlrpc.php>
order deny,allow
deny from all
allow from 123.123.123.123
</Files>
 

crystygye

Well-Known Member
Registered
Full Member
#5
Am incercat ambele variante. La fel. Ce as putea incerca? Modul xml este instalat pe server.
Nu am blocat nimic, decat acel update. Nu pot sa inteleg ce s-a schimbat de ce este blocat.
 

AlexH

Merg pe strada catre Mine...
Membru personal
Administrative
Freelancer
SEO Expert
#6

AlexH

Merg pe strada catre Mine...
Membru personal
Administrative
Freelancer
SEO Expert
#8
Da un restart la apache / nginx si vezi daca merge.
Verifica htaccess daca nu cumva este blocat.
Sterge cache din cloudflare daca ai sau pe site.
Deschide php info si vezi daca iti apare in lista.
 

crystygye

Well-Known Member
Registered
Full Member
#9
Am incercat cu linia in function. In htaccess am dat allow all ptr xml sa vad daca merge. Nici un ip nici cu all nu merge.
Am dat reboot, restart, clear cache in plugin, cloudflare. Am urmat tutorialul de la cloudflare ptr jetpack. cu pagerule, modificari in wp-config, etc.
Ambele module sunt instalate.
Cand intru pe link sa fac test la xml imi da "XML-RPC server accepts POST requests only."
Am dat disable la cloudflare firwall.

Totul degeaba. Cand dau comanda curl de la jetpack imi da faultcode 32700
 

AlexH

Merg pe strada catre Mine...
Membru personal
Administrative
Freelancer
SEO Expert
#10
In htaccess am dat allow all ptr xml sa vad daca merge
Daca nu ti-a mers sterge regula pentru ca e posibil sa intre in conflict. Daca ai facut una si nnu merge stergi si testez alta, nu lasi toate acolo.
alte solutii:
1. vezi daca portul 80 iti este accesibil. Aveam pe cineva care primea mereu eroarea asta pentru ca sistemul de securitate ii bloca portul 80 dupa ce era infectat.
Cod:
netstat -ptnl | grep ":80"
2. dezactiveaza toate pluginurile si apoi activeaza jetpack
3. dezactivare, sterge si reinstall la jetpack
4. mareste valoarea RAM din wp-config sau php.ini
5. dezactiveaa firewall daca ai unu
6. daca rulezi sub Varnish mai bine dezactivezi ca aduce numai problema, asta daca nu cumva ai cunostinte avasate de setare.
7. ce panel folosesti?
 

crystygye

Well-Known Member
Registered
Full Member
#11
Dupa ce incerc sterg tot ce am modificat.

2. facut
3. facut
4. facute toate setarile recomandat ptr wordpress
5. am facut ambele variante
6. nu am varnish
7. nu am panel.am instalat doar modulele strict necesare ptr a functiona wordpress. totul fac din consola/ftp. nici phpmyadmin nu am.

Tot nu merge. Primul punct, verifica port 80 am dat comanda aia dar mi-a aparut doar ">" . Cred ca nu e buna comanda?
Totul s-a intamplat fix dupa ce am facut upgrade la php 7.x (acum vreo 2-3 luni gen). Cam mare coincidenta sa nu fie din cauza lui. Doar la php am facut update, nimic altceva.
 

AlexH

Merg pe strada catre Mine...
Membru personal
Administrative
Freelancer
SEO Expert
#12
verifica port 80 am dat comanda aia dar mi-a aparut doar ">"
Asa trebuie sa apara:
Cod:
netstat -ptnl | grep ":80"
tcp        0      0 185.134.103.193:80      0.0.0.0:*               LISTEN
Cred ca de aici este problema. Verifica apache si nginx daca apare portul 80 listen.
 

AlexH

Merg pe strada catre Mine...
Membru personal
Administrative
Freelancer
SEO Expert
#13
Uite cum apare pe alt server aceiasi comanda:
Cod:
netstat -ptnl | grep ":80"
tcp        0      0 21.21.45.10:80         0.0.0.0:*               LISTEN      17731/nginx: master
tcp        0      0 21.21.45.10:8080       0.0.0.0:*               LISTEN      17700/httpd
tcp        0      0 127.0.0.1:8081          0.0.0.0:*               LISTEN      17700/httpd
tcp        0      0 127.0.0.1:8084          0.0.0.0:*               LISTEN      17731/nginx: master
 

Reclama

Loading...

Reclama Ta Aici

Stiri Monezi Virtuale

Reducere pentru Vacanta

nCheck

Sus